Announcement

Collapse
No announcement yet.

No flasher , new relay

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No flasher , new relay

    Hi everyone.
    First I have a gts 89 with rb25det swap running on z32 ecu.
    I bought the car and the flashers were not working. I changed the relay ( niles if302) for another used one but don't have flasher either. It works on hazard but when I try with the "arm" , nothing happen. What should I check ?

    Thanks

  • #2
    I know there's a relay (sounds like the relay you have already mentioned) that's bolted on top of bottom cover under drivers side of dash (need to remove bottom of dash). That relay can fail and make indicators not work properly if activate via stalk. Same with blown bulb in one of the indicators.

    With relay under dash, from memory can use a Bosch relay to replace it. Sometimes the stalk part fails on Skylines and needs to be replaced (not sure if it can be pulled apart via clips, repaired, but usually the contacts wear or get dirty and just need to be cleaned, bent back into place).
    Last edited by Skym; 05-05-2013, 06:25 AM.
    RESPONSE MONSTER

    The most epic signature ever "epic".

    Comment


    • #3
      Could it be your turn signal arm its self? Last year i was having issues with my indicators, and high beams. The culprit turned out to be the indicator arm.
      Originally posted by victoriaGTR
      tire smoke makes my wiener tingle.

      Comment


      • #4
        I changed the arm and the relay , and there is still nothing working !!! So depressed . perhaps the arms I have now is still not working ? And maybe the relay isnt either ?
        Else , what it could be ? Is there anything else related to flasher ?

        Comment


        • #5
          Check engine bay fuse box. But I think that engine bay fuse box only affect's headlight's, etc. The headlight's are switched to full beam via the stalk, so one would think a fuse in that fuse box could be a cause or if full beam doesn't work, could be stalk related.

          From memory, when the relay under dash goes it makes the indicator light's act like hazard light's on dash.

          But there has to be a wiring problem somewhere under dash (some wiring you modified or didn't attach to a plug??) for it to not reach indicators from the stalk.
          Last edited by Skym; 05-06-2013, 05:14 PM.
          RESPONSE MONSTER

          The most epic signature ever "epic".

          Comment


          • #6
            I didnt do the swap , I never modified the harness myself but I start thinking that the last owner was a b$#ch... What I dont understans i that the hazards work but not the indicators. Do you have the wiring diagram of the flasher ? :S

            Comment


            • #7
              Going by R33 fuse box diagram in link below, there's fuses under dash for stalk, hazards (could have a blown indicator / turn signal fuse under dash and hazard fuse might be ok) -

              http://www.paulr33.com/diagrams/r33-fusebox.html

              Back of manuals (R32, R33 manuals if done a swap with R33 engine) has the wiring diagrams -

              http://www.jpnz.co.nz/afawcs0131170/.../products.html
              RESPONSE MONSTER

              The most epic signature ever "epic".

              Comment


              • #8
                Thank you ! I'll check this out this week and gives you some news !

                Comment


                • #9
                  The R32 diagram is on a sticker on the back of the lid that you pull to access the fuse box under dash.

                  This is what they mean (in English) -

                  Last edited by Skym; 05-07-2013, 06:53 AM.
                  RESPONSE MONSTER

                  The most epic signature ever "epic".

                  Comment

                  Working...
                  X